› MySQL 5.5 Community Server
› MySQL 5.6 Community Server
› Percona Configuration Wizard
› XtraBackup 搭建主从复制
Great Sites on MySQL
› Percona
› MySQL Performance Blog
› Severalnines
推荐管理工具
› Sequel Pro
› phpMyAdmin
推荐书目
› MySQL Cookbook
MySQL 相关项目
› MariaDB
› Drizzle
参考文档
› http://mysql-python.sourceforge.net/MySQLdb.html
copyrenzhe
V2EX  ›  MySQL

mysql 升级之后,某些表打开报: 2013 - Lost connection to MySQL server during query

  •  
  •   copyrenzhe · Aug 8, 2016 · 7240 views
    This topic created in 3708 days ago, the information mentioned may be changed or developed.

    mysql 从 5.1 升级至 5.7 之后,部分数据库的部分表,执行任何操作均报错: 2013 - Lost connection to MySQL server during query. 直接在命令行中执行

    mysql> select * from AO_9412A1_AOTASK; ERROR 2006 (HY000): MySQL server has gone away No connection. Trying to reconnect...
    Connection id: 2 Current database: confluence ERROR 2006 (HY000): MySQL server has gone away No connection. Trying to reconnect...
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (111) ERROR: Can't connect to the server

    网上的解决方案比如设置

    max_allowed_packet=500M;
    wait_timeout = 6000
    

    均无效

    请问这个什么原因导致的,该如何解决呢,谢谢

    Supplement 1  ·  Aug 9, 2016
    1. 打不开的两张表数据量都不大
    2. mysql 更新方式是,更换了 yum 源为 mysql 官方源,然后直接 yum update 然后 mysql_upgrade
    3. 打不开的表即使用命令行都删除不了
    17 replies  •  2016-08-09 18:16:50 +08:00
    pubby
        1
    pubby  
       Aug 8, 2016 via Android   ❤️ 1
    看 mysql 服务器上的错误日志
    copyrenzhe
        2
    copyrenzhe  
    OP
       Aug 8, 2016
    @pubby 日志太长了, append 不上来,而且 log 里没有 error 信息
    cevincheung
        3
    cevincheung  
       Aug 8, 2016   ❤️ 1
    想知道怎么升级的,有没有数据导出导入
    caola
        4
    caola  
       Aug 8, 2016
    mysql 只支持 mysqli 或者 pdo 方式连接数据库,不支持老旧的 mysql 连接方式
    caola
        5
    caola  
       Aug 8, 2016   ❤️ 1
    上面错了,是 mysql5.7 只支持 mysqli 或者 pdo 方式连接数据库,不支持老旧的 mysql 连接方式。
    pubby
        6
    pubby  
       Aug 8, 2016 via Android   ❤️ 1
    没进行 mysql _upgrade ?
    而且这两个版本配置文件差别也挺大

    估计有错误服务没起来
    prondtoo
        7
    prondtoo  
       Aug 8, 2016 via Android
    前几天同事在帮个客户处理类似问题,楼主该不会是那个客户吧.....
    JhZ7z587cYROBgVQ
        8
    JhZ7z587cYROBgVQ  
       Aug 8, 2016   ❤️ 1
    是不是用 goproxy 和 dal 了?我之前碰到是 goproxy 超时时间设置得太短了
    quadpixels
        9
    quadpixels  
       Aug 9, 2016   ❤️ 1
    我遇到过一个类似的问题,问题的原因是 [超时]
    是因为用 [龙芯笔记本电脑 8089A] 进行数据库更新时由于 CPU 性能低所以导致查询运行的时间长了很多。

    说到设定超时时间,题主是在服务端设定,但是我是在客户端设定的。所以也许可以试试看在客户端设定。
    就是在客户端执行这个一句的查询就行了:

    SET @@LOCAL.wait_timeout=800;

    其中 800 秒是我这个例子中设定的超时。
    copyrenzhe
        10
    copyrenzhe  
    OP
       Aug 9, 2016 via Android
    @cevincheung 没有数据导入导出,更换 mysql 源后, yum update 的
    copyrenzhe
        11
    copyrenzhe  
    OP
       Aug 9, 2016 via Android
    @caola 那为什么会只有部分表打开删除有问题呢,而且我直接命令行操作也不行,直接删除表都不行
    copyrenzhe
        12
    copyrenzhe  
    OP
       Aug 9, 2016 via Android
    @prondtoo 并不是……
    copyrenzhe
        13
    copyrenzhe  
    OP
       Aug 9, 2016 via Android
    @pubby 进行了 mysql_upgrade ,没有错误提示…
    copyrenzhe
        14
    copyrenzhe  
    OP
       Aug 9, 2016 via Android
    @quadpixels 奇怪的是,打不开的那两张表,数据都比较少,其他数据量大的表打开反而没问题
    copyrenzhe
        15
    copyrenzhe  
    OP
       Aug 9, 2016 via Android
    @jason0916 打不开的两张表中,一张是空表没数据,讲道理应该不会超时才对
    JhZ7z587cYROBgVQ
        16
    JhZ7z587cYROBgVQ  
       Aug 9, 2016   ❤️ 1
    @copyrenzhe 嗯,我这边之前也是新系统,也是空表,就是 goproxy 超时太短导致连接丢失了,你问问你那边的运维看看?也有可能不是我说的这个问题,那样的话我就真不知道了,数据库水很深啊 orz
    copyrenzhe
        17
    copyrenzhe  
    OP
       Aug 9, 2016
    @jason0916 目前已经还原回 mysql5.1 ,仍然感谢!
    About   ·   Help   ·   Advertise   ·   Blog   ·   API   ·   FAQ   ·   Privacy   ·   Solana   ·   862 Online   Highest 6679   ·     Select Language
    创意工作者们的社区
    World is powered by solitude
    VERSION: 3.9.8.5 · 90ms · UTC 18:39 · PVG 02:39 · LAX 11:39 · JFK 14:39
    ♥ Do have faith in what you're doing.